Back to 10th scale

img_50901

Yesterday I went to OCRC Raceway and got my PR Racing 10th scale buggies up and running. It’s been a while! Last time I was in America I ran the Schumacher cars, so this was the first time I got to run the PR Racing buggies on a US indoor clay track. I’m running the S1 V3 Mid Motor car with the stand up gearbox for 2wd, and the SB401 4wd.

Yesterday I didn’t get to practice at all, as there was a club race in the afternoon, so I got my 2wd ready and threw it out there! I was only about 2.5 seconds off the pace, per lap! And that’s on a 20 second lap time! The car felt super stable and really easy to drive, I just didn’t have steering!

So today I went back and tried a few things. I also got my 4wd on the track. The 4wd felt really good immediately. I just raised the ride height from 21/21 to 22/22, and punched it! I’m not sure what the lap times are supposed to be in 4wd, but I feel like I am close, probably about 0.5s off, but I should be able to figure that out.

For the 2wd I laid the front shocks down to the middle hole, outside on arm, I used the optional front arm holder that moves the arms back, I lowered the car to 21/21, and it was a lot faster. Now I am only 1 second off the pace! These American’s are ridiculously fast with the 2wd buggies. I will be going back club racing on Sunday, so let’s see if I can do a bit better. Hopefully I will soon have some good setup advice for everyone running PR Racing cars on dirt!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: